Skip to Main Content

Q. I'm having trouble accessing Scopus? Why?

With Javascript enabled on Firefox 38.0.5, the library's Scopus link (or specifying URL www.scopus.com) results in endless "Connecting..." display with no connection ever made.

When accessing Scopus link (provided on library home page) using the OHSU Citrix remote access version of Internet Explorer 10, there is an error message returned by Scopus claiming that "IE8 or higher is required". The IE information page verifies that the OHSU Citrix version of IE is indeed IE10.

Answered By: Amanda Woods
Last Updated: Sep 09, 2015     Views: 155

For problems accessing Scopus via Firefox 38.0.5, try deleting temp files to see if that is the cause of the problem. Instructions for deleting temp files can be found online.

For problems accessing Scopus via IE10 on WTS, the issue might be caused by the Compatibility View mode being turned on. Compatibility View mode is generally a default setting for all OHSU systems, including WTS.  Instructions for turning off Compatibility View mode can be found online; please restart your browser and try accessing Scopus again once Compatibility View mode is no longer active.

If you're still having trouble accessing Scopus, please contact us with details about your situation and we will be happy to get back to you with help. 

 

Other Ways to Contact Us